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Expression Web



Nota in1 akan menerangkan secara asas bagaimana untuk membina tapak web, membuat laman
HTML. membuat elemen CSS dan paparkan laman web yang telah siap pada pelayar web.

Membina Tapak Web Baru

Sebelum mulakan dengan membuat laman web. diterangkan terlebih dahulu cara untuk membuat
tapak web menggunakan Ms Expression Web:
1. Pilih Menu Site => New Site
2. Dialog New akan dipaparkan dan sila pilih General pada kolum pertama dan pilih
Empty Site pada kolum yang kedua.

General d Qne ERpE S i P s
JEmptysite - | Create anew site with nothing in it.
Tesicloles o Import Site Wizar
Options
[ 7] Add to current site
[ ] Use Encrypted Connection (SSL)
Specify the name and location of the new site
Location: C:\Users\adnan\Documents\My Web Sites\mysite v
Add to Managed List Name: |mysite

o< ][ concel |

Apabila Empty Site dipilih, Ms Expression Web akan wujudkan satu folder kosong di mana
folder ini akan bertindak sebagai tapak web dan akan menyimpan semua fail dan subfolder nanti.



Ms Expression Web juga akan memberikan nama secara automatik kepada tapak web anda iaitu
“mysite” dan anda boleh menukarkan nama tersebut pada ruangan Name. Lokasi folder juga
boleh ditukar apabila anda menekan butang Browse dan boleh letakkan di mana-mana lokasi
dalam PC anda.

Membuat Laman Web Baru

Untuk membuat dokumen HTML yang baru, sila pilih File=>New=>Page dan tentukan jenis
dokumen yang anda mahu buat. Untuk kursus ini, kita akan buat dokumen HTML sahaja dan
anda boleh pilih File=>New=>HTML.

Sebelum anda lakukan apa-apa pada dokumen ini1, pastikan anda namakan dan dahulu dokumen
anda sebagai “index.html” atau “default.html” sebagai laman utama anda. Bagi lain-lain
dokumen yang anda wujudkan nanti, anda boleh berikan apa-apa nama tetapi pastikan tiada
ruang kosong dan karekter khas pada nama yang diberi pada dokumen tersebut.

Seterusnya klik pada File=>Properties untuk lakukan fungsi-fungsi berikut:
1. Pada tab General, masukkan Title untuk memberikan tajuk laman web anda di mana
tajuk ini akan dipaparkan pada bahagian paling atas di setiap pelayar web. Tajuk ini juga
akan disimpan dalam senarai Bookmark apabila seseorang menanda laman web anda.

!\)

Pada tab Formatting, anda boleh tentukan warna latar belakang, warna teks dan warna
untuk hyperlink.

3. Seterusnya pada tab Advanced anda boleh tentukan margin top. bottom, right dan left
bagi kandungan untuk setiap laman web anda



Page Properties ¥
Location: |file:///C: JUsers/adnan Documents /My Web Sites/index.htm
Title:

Page description:

Keywords:

Base location: |

Default target frame: | [.'i]
Background sound

Location: | Browse... |

Loop: |0 *| [V|Forever

ok ][ concel |

Membuat Rekabentuk laman dengan Layer

Sekarang anda telah ada tapak web dan laman utama, seterusnya anda perlu masukkan
kandungan dalam laman web anda. Mari mulakan rekabentuk kandungan dengan penggunaan
layer.

Layer dalam Expression Web menggunakan tag <div> dengan CSS dan posisi absolute. Ini
bermaksud anda boleh meletakkannya di mana-mana pada laman web dan bergantung kepada
lokasi koordinat piksel yang ditentukan. Anda boleh masukkan element teks. imej dan
sebagainya ke dalam layer.

Penggunaan layer adalah sangat popular dalam rekabentuk laman web sekarang kerana ia
memberikan kawalan yang tepat dalam menentukan lokasi sebarang elemen/komponen web.

1. Untuk masukkan layer ke dalam laman web, klik ikon layer di dalam panel Toolbox dan
heret (drag) ke dalam laman web. Layer akan dipaparkan secara automatik pada
bahagian atas sebelah kiri.



(89

Toolbox * Snippets
+ HTML
~ Tags
B <div>
<span>

: Break

B Horizontal Line
B Image

& Inline Frame
‘"-ALayer

9 Paragraph

+~ Form Controls
7 Advanced Button

g Drop-Down Box

e

Anda boleh ubah saiz dan kedudukan layer dengan cara klik pada layer ini. Anda juga
boleh menggunakan panel CSS Properties untuk mengubah lebar dan tinggi mengikut
ukuran piksel.

Untuk masukkan imej, sila pilih Insert=>Picture=>From File dan pilih imej yang ada
dalam PC anda.

Kekotak dialog Accessibility Properties akan dipaparkan. Sila masukkan keterangan
gambar. Untuk contoh ini, masukkan “Foto 3 ekor kucing kesayangan saya”.

-
Accessibility Properties LM

V| Alternate text: [

Long description: | Browse...

(7] show this prompt when inserting images [~ oK | [ Cancel |




Anda boleh gunakan panel Tag Properties untuk melihat sebenar imej yang digunakan dan
kemudian ubah saiz layer mengikut saiz imej pada panel CSS Properties. Untuk kursus ini saya
letakkan saiz layer adalah 800px (lebar) dan 200px (tinggi).

(Z] Laman Kucing Saya (C:\Users\adnan\Documents\My Web Sites\indexhtm) - Microsoft Expression Web4 4

File Edit View Inset Format Tools Table Site DataView Panels Window Help

A-EE-E0 RS- D X CIET

Folder List ® x  GiteView | index.htm®

index.htm <body>| <div#ayeri>
320 bytes ;

n C:\Users\adnan\Documents'\My Web Sites
B _oivate
P images

D button2.jpg

O button3.jpg

D button4.jpg

e

B new_page_1him

Tag Properties CSS Proper.. R X

o+ Summary

Applied Rules
<div#layer1>

CSS Properties

Design  Split




Tambah dan Ubahsuai Layer

Untuk seterusnya kita masukkan lagi 3 layer dan masukkan kandungan dalam setiap layer
berkenaan. Kita akan gunakan panel CSS Properties untuk menetukan posisi setiap layer
dengan lebih tepat dan sempurna.

1. Sila pilih dan klik ikon layer pada panel Toolbox dan letakkan pada sebelah kiri laman
web seperti rajah di bawah. Masukkan teks seperti berikut:
a. Menu Utama
b. Aktiviti Saya
c. Hubungi Saya
d. Lain-lain Pautan

Selamat Datang ke

Laman

g
Menu

Laman Utama
pAktiviti Saya ¢
Hubungi Saya
Lain-lain Pautan
o o 'a)

L

2. Seterusnya masukkan layer yang ke dua dan letakkan di tengah laman web seperti rajah
di bawah.

3. Pastikan kursor anda berada di dalam layer ke dua dan kemudian pilih menu

Insert=>Picture=>From File untuk mencari gambar yang sesuai dan letakkan dalam

layer ini.



Menu:

Laman Utama
Aktiviti S
Hubungi Saya
Lain-lain Pautan

. Ubahsuai lebar dan tinggi layer untuk disesuiakan dengan saiz imej yang dimasukkan
menggunakan panel CSS Properties.

. Kemudian masukkan layer yang ke tiga dan letakkan posisi sebelah kanan laman web.
Lihat rajah di bawah.

. Anda boleh masukkan teks sendiri ke dalam layer atau masukkan “dummy text” untuk
penuhkan ruangan ini. Untuk “dummy text” sila pergi ke laman http://ms.lipsum.com
dan salin perenggan yang pertama sahaja.

. Sebelum anda paste teks yang telah disalin, pastikan kursor anda berada dalam layer
yang ke tiga tadi. Seterusnya klik menu Edit=>Paste Text...

. Satu kekotak dialog Paste Text akan dipaparkan seperti di bawah dan pilih Normal
paragraphs without line breaks. Seterusnya klik OK

8



R
Paste Text (2 [l |
[l |
As:
e o ]
One <pre> formatted paragraph
Many <pfe> formatted paragraphs

Normd agrap wiﬂ'lhebredcs

Pastes all of the text and removes any paragraph, row, or ather types
of line breaks. If the text to convert contains an empty line or row,
Expression Web endoses the text that follows the empty line or row in a
new tag set.

[¥] Preserve hyperlinks

9. Kemudian masukkan tajuk bagi cerita yang dipaste tadi. Letakkan kursor pada posisi kiri
dan paling atas dalam layer yang ke tiga dan kemudian tekan kekunci Enter pada papan
kekunci untuk masukkan dua baris ke bawah. Untuk contoh ini masukkan tajuk sebagai
“Kisah Kucing Saya”.




Format Headline Styles

Dalam bab ini akan diterangkan format untuk headline (Kepala Tajuk) menggunakan tag header
dan boleh menukar style headline melalui ubahsuai jenis font dan saiz.

1. Higlight tajuk yang dimasukkan tadi 1aitu “Kisah Kucing Saya”.
2. Pada toolbar menu pilih Heading 1 <h1> dan teks akan automatik akan menjadi bold
dan berubah saiz.

Format Tools Table Site DataView Panels Window Help

Ll R [Default Font)
{None)
Paragraph <p>
Heading 1 <hl>
Heading 2 <h2>
Heading 3 <h3>
AP PREESIESY Heading 4 <hd >
Heading 5 <h5>
Heading 6 <h6>

Unordered List <ul> ) L:L
i Kisah
Definition <dd ¢ o

Addl:‘eslso:‘a:idr;p Kucin g
Preformatted <pre> S a)'a

Block Quote <blockquote> ==
Apply Styles... Lorem ipsum dolor sit
amet. consectetur

PONE ST P

3. Anda boleh menukar style heading ini menggunakan CSS Style. Untuk lakukan ini sila
klik New Style pada panel task Apply Styles atau Manage Styles

4. Kekotak dialog New Style akan dipaparkan. Pada kolum Selector, sila pilih h1

5. Pada Font Category. pilih font-family sebagai Arial, Helvetica, sans-serif

6. Masukkan font-size sebagai 16px 1aitu dalam ukuran piksel.

7. Seterusnya klik OK dan style h1 akan berubah mengikut kriteria yang dimasukkan tadi.

10



Gunakan CSS Untuk Align Images

[] Apply new style to document selection

Selector:  hi v
Definein: |Current page v| vRL: | Yo
I Category:
Blo " font-family:  Arial, Helvetica, sans-serif w
Background font-size; 16| viE) Px v text-decoration:
Border : - [ underiine
Border Radius fmt st [i overline
Box font-style: v =
Position [jlhe—ﬂvough
font-variant: hd
Layout [ blink
List text-transform: - [ none
% -
able color: i Lf‘
I
|
|
Preview:
AaBbYyGgLlJj
Description: font-family: Arial, Helvetica, sans-serif
e  ______—— aaaaaaaaaa——

Seterusnya kita akan masukkan imej yang mengandungi cerita dan tajuk cerita dan buat style
align untuk imej supaya teks akan mengelilingi imej tersebut.

L S

Letakkan kursor pada permulaan perenggan yang pertama.
Pilih Insert=>Picture=>From File untuk pilih imej yang hendak dipaparkan
Kekotak Accessibility Properties akan dipaparkan dan seperti biasa masukkan

keterangan dalam kolum description.
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4. Apabila imej dimasukkan, teks secara automatik akan berada di bawah imej. Lihat rajah
di bawah.

Menu Utama Kisah Kucing Saya
Laman Utama

Aktiviti Saya
Hubungi Saya
Lain-lain Pautan

o
!

i
l
|
!

i

u = Lorem ipsum dolor sit
anet,oonsectetmadpxsmeit InndmoﬁstonecmoleshemnmcsedaccmnsmPhasehsnecfeﬁs
non ante mollis cursus. Vivamus velit erat, ultrices vel massa sed, dictum faucibus orci. Curabitur tortor nisl,
lobortis sit amet interdum eu, ultricies ut erat. Nullam ut lacus lacus. Aliquam neque mi, sollicitudin nec leo

5. Jika anda mahukan align imej berada di sebelah kiri atau kanan dan teks akan
mengelilingi imej berkenaan, anda perlu membuat perubahan pada aligment ime;j
berkenaan. Untuk tujuan ini kita akan buat satu style CSS untuk digunapakai pada ime;j
atau mana-mana elemen yang ada.

Klik New Style pada panel Apply Styles.

Kekotak New Style akan dipaparkan. Pada ruangan Selector masukkan .img-right

Pada ruangan Category sila klik pada Layout dan pada ruangan float pilih right

Pada ruangan Box Category, pergi ke ruang Margin dan uncheck pada kotak Same for
all. Masukkan 10px dalam ruangan bottom dan left

10. Seterusnya klik butang OK

Q2 go = oN
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Selector:  .img-right

v [ Apply new style to document selection

Define in: [Curentpage v] URL: v Browse
Category:
::dt( padding: [¥]Same for all margin: [~ | Same for all
o - - o B
Border right: v =7 | PX right: v 24| px
Border Radius [
h Eotinm: px bottom: | Il v px v
Position left: . px left: 10 v = X v
L_ay box shadow™:
List - = =
Table X v = v | > [ B8l ~

blur®; v [ | px spread®: | v = |px ~

color®: v [ inset®: -

*Requires a CSS 3 compliant browser to view
Preview:
AaBbYyGglLLUj
Description: float: right; margindeft: 10px; margin-bottom: 10px
(o< ][ concel | [ apoty ]

11. Seterusnya klik pada imej yang dimasukkan tadi dan pada panel Apply Styles klik pada

style .img-right.

12. Imej secara automatik akan berada pada sebelah kanan dan teks akan mengelilingi ime;j

tersebut di sebelah kiri. Lihat rajah di bawah.

13




Mem Utama  Kisah Kucing Saya
Am || »
‘ﬁ JSIYB Lorem ipsum dolor sit
Seym amet, consectetur
Lain-lain Pautan aioiecing et Inid
mollis arcu. Donec
molestie eu nunc sed

quam ac ex interdum, in volutpat nibh pharetra. Vestibulum a auctor elit, et varms nibh. Mauris condimentum
nisi a pharetra tempor. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis
egestas. Nunc sed nisl nec orci euismod ulfrices ac non augue. Proin accumsan sit amet nisi at viverra.

Membuat Pautan

Expression Web menyediakan kaedah untuk membuat pautan pada laman web sendiri atau
laman web luar yang amat senang. Sebelum membuat pautan pada laman web yang lain, satu

laman web yang lain hendaklah diwujudkan. Untuk membuat laman web yang baru, sila ikuti
langkah berikut:

1. Pilih menu File=>New=>HTML dan satu laman web yang kosong dipaparkan di sebelah
laman web index.htm

2. Pilih File=>Save dan anda boleh berikan sebarang nama pada dokumen ini. Pastikan
tiada ruang kosong dan karekter khas pada nama tersebut. Untuk kursus ini saya berikan
nama “hubungikami.html”

3. Pilih File=>Properties untuk memberikan Tajuk, warna latar belakang, margin dan
sebagainya

14



4.

5

Masukkan teks pada laman ini untuk mengenal pasti bahawa ini adalah laman web yang
lain. Sebagai contoh, dimasukkan teks “Hubungi Kami” dan berikan format dengan tag
<hl>

Site View  index.htm hubungikami.html x

<body>| [<div#ayer1>| <h1>

Hubungi Kami

Seterusnya pilih File=>Save untuk menyimpan laman web ini dan kita sudah boleh
lakukan pautan pada laman web ini

Kemudian pergi semula ke laman web yang pertama iaitu fail “index.htm” dengan cara klik
pada tab index.htm pada bahagian atas ruang kerja (workspace). Untuk membuat pautan pada
laman web yang pertama ini, sila ikuti langkah berikut:

9

Highlight pada perkataan “Hubungi Kami” pada layer sebelah kiri.

Pilih menu Insert=>Hyperlink dan satu kekotan dialog Insert Hyperlink akan
dipaparkan

Pilih mana-mana fail yang hendak dipautkan dengan cara klik pada salah satu senarai fail
yang dipaparkan. Sebagai contoh, klik pada fail “hubungikami.html”

Klik OK dan pautan akan disetkan secara automatik

15



nsert yperink o o e

Link to: Text to display: lHubungi Saya

Lookin: |(8] My Web Sites

Place in This
Document

“.

Create New
Document

Browsed
Pages

Recent
Files

index.htm (open)
\. _private
| images
|®| button2.jpg
& button3.jpg
& button4.jpg
2| new_page_1.htm

% hubungikami.html (open)
5

\

Address:  |hubungikami.htmi

&

E-mail Address

Untuk membuat pautan pada laman web yang lain, sila ikuti langkah-langkah berikut:

Highlight pada teks “Lain-lain pautan” pada layer sebelah kiri.

Pilih menu Insert=>Hyperlink

Satu kekotak Insert Hyperlink akan dipaparkan. Pada ruangan Address sila masukkan
alamat URL yang penuh laman web dan contoh di sini anda boleh masukkan URL
http://www.kucing.my/

4. Klik OK dan pautan akan dibuat secara automatik

W R -

Untuk menguji pautan anda yang anda wujudkan tadi, anda perlu paparkan laman web ini pada

pelayar web.

1. Pastikan semua dokumen laman web telah disimpan dengan cara klik menu File=>Save
2. Kemudian pilih File=>Preview in Browser dan pilih salah satu pelayar web yang

dipaparkan.
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Edit View

Insert Format Tools Table Site DataView Panels Window Help

New

|7 Open... Ctrl+0
Recent Files i~ Site View index.htm® x  hubungikami.html
{ Close STeRTNR, y
- <body>| | <div#layer2>| <a>
Sav | ‘A T =
el Save S Menu Utama Kisah Kucing Saya
(&) Save As... Laman Utama
(# Save All Aktiviti Saya Lorem ipsum dolor sit
Hubungi Saya amet, consectetur
Import ’ Lain-lain Pautan adipiscing elit. In id
ollis arcu. Done
g Display in SuperPreview Shift+F12 T,\L.-.:- - m_:: sced
Preview in Browser » < 1Chrome FE2 \has nec
Print * & 2Internet Explorer9 Iis
Properties... < 3 Internet Explorer 9 (1024 x 768) velit
i . € 4Firefox 3501 [N
I ntrc
), 5 Firefox 35.0.1 (1024 x 768) bus
. rtor
X Exit <% 6 Chrome (1024 x 768)
met
Preview in Multiple Browsers aes
Preview in Multiple Browsers (1024 x 768) s :
=que mi,
div=l >
S Edit Browser List... _
O PTG IT G ATE R 1IN IMPQ
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3. Apabila pelayar web telah dipilih, rajah seperti di bawah akan dipaparkan dan anda boleh
klik pada pautan yang telah diwujudkan tadi.

Selamat Datang ke

_— 4
Laman ?"e/b' Kucifig Saya

.

Menu Utama
Faman Ftama Kisah Kucing Saya
Aktvin Sava ) )
Bubungi Sava Lorem psum dolor sit
I Lain-lain Pautan At consectetur
adipiscing elit. In:d
mollis arcu. Donec
molestie en nunc sed
accumsan Phasellus
nec felis non ante
mollis cursus. Vivamus
velit erat, ultrices vel
massa sed. dictum
faucibus orci.
Curabitur tortor misl.
loborts sit amet
wmterdum eu. ultricies
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